// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(?\d{3}\)?-\d{3}-\d{4}").unwrap();
let string = "123-456-7890
(123)-456-7890
(abc)-123-4567
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}