re = /^(?!.*(\d)\1{5}).*$/m
str = 'd111111
d11111
d999999
d12222222222
d99999
abchdjr12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end