using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class=""dtend"" title=""\K[^""]+(?=T)";
string input = @"</abbr></td><td><abbr class=""dtend"" title=""2014-04-19T00:00:00+00:00"">19 Apr 2014</abbr></td></tr>";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}