$re = '/<(|\/)(?!\?).*?(|\/)>/';
$str = '<span style="font-size: 8pt;" >Спасибо за заказ! Номер Вашего заказа <?= $order->id ?> Ваш Заочник.бай
</span>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);