use strict;
my $str = 'https://my.tase.co.il
https://accounts.tase.co.il
https://maya.tase.co.il/reports/mymessages
https://maya.tase.co.il/reports/favorites
https://maya.tase.co.il/account/notification
https://info.tase.co.il/Management/GeneralPages/Pages/PersonalFolder.aspx
https://info.tase.co.il/Management/GeneralPages/Pages/Registration.aspx
https://info.tase.co.il/Management/GeneralPages/Pages/Change_Password.aspx
https://info.tase.co.il/Management/GeneralPages/Pages/UsersSearchIndex.aspx
https://info.tase.co.il/Management/GeneralPages/Pages/Security%20Search.aspx';
my $regex = qr/https:\/\/(?:(?:accounts|my)\.tase\.co\.il|maya\.tase\.co\.il\/(?:reports\/(?:mymessages|favorites)|account\/notification)|info\.tase\.co\.il\/Management\/GeneralPages\/Pages\/(?:PersonalFolder|Registration|Change_Password|UsersSearchIndex|Security%20Search)\.aspx).*/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}