# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https:\/\/(?:(?:accounts|my)\.tase\.co\.il|maya\.tase\.co\.il\/(?:reports\/(?:mymessages|favorites)|account\/notification)|info\.tase\.co\.il\/Management\/GeneralPages\/Pages\/(?:PersonalFolder|Registration|Change_Password|UsersSearchIndex|Security%20Search)\.aspx).*"
test_str = ("https://my.tase.co.il\n"
"https://accounts.tase.co.il\n"
"https://maya.tase.co.il/reports/mymessages\n"
"https://maya.tase.co.il/reports/favorites\n"
"https://maya.tase.co.il/account/notification\n"
"https://info.tase.co.il/Management/GeneralPages/Pages/PersonalFolder.aspx\n"
"https://info.tase.co.il/Management/GeneralPages/Pages/Registration.aspx\n"
"https://info.tase.co.il/Management/GeneralPages/Pages/Change_Password.aspx\n"
"https://info.tase.co.il/Management/GeneralPages/Pages/UsersSearchIndex.aspx\n"
"https://info.tase.co.il/Management/GeneralPages/Pages/Security%20Search.aspx")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.