use strict;
my $str = '==GFTX=BL2++UMB01+MPDP01+00010-PIO01:04';
my $regex = qr/(=|\+|-|:)+/p;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";