using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:class=""priceValue"">\s*)(\d*\.\d+)";
string input = @"<tr class=""tr_standard""><td>Milk (regular), (1 liter) </td> <td style=""text-align: right"" class=""priceValue""> 2.45 TL</td>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}