import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:class=\"priceValue\">\\s*)(\\d*\\.\\d+)";
final String string = "<tr class=\"tr_standard\"><td>Milk (regular), (1 liter) </td> <td style=\"text-align: right\" class=\"priceValue\"> 2.45 TL</td>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}