package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(*CR)\w+.\w+`)
var str = `Line1\nLine2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}