using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(*UCP)\d+ :: \w+";
string input = @"1۳۲١८৮੪ :: Aれã¾ëž˜ë„áš áš ±áš©";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}