package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\$.+[0-9\,])`)
var str = `↓ $1,725,000 for sale`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}