$re = '/(<\/?)(.+?)(>)/';
$str = '<head></head>';
$subst = "<span>$1</span><span>$2</span><span>$3</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;