import Foundation
let pattern = #"(<\/?)(.+?)(>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<head></head>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span>$1</span><span>$2</span><span>$3</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)