#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<a.*? href=[^>]*><img.*? alt=")("[^>]*></a>)"
Local $sString = "<a href="something.com"><img src="blah.jpg" alt="Game"></a>" & @CRLF & _
"<a href="something.com"><img src="blah.jpg" alt=""></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")