package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<a.*? href=[^>]*><img.*? alt=")("[^>]*></a>)`)
var str = `<a href="something.com"><img src="blah.jpg" alt="Game"></a>
<a href="something.com"><img src="blah.jpg" alt=""></a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}