re = /(<a.*? href=[^>]*><img.*? alt=")("[^>]*><\/a>)/
str = '<a href="something.com"><img src="blah.jpg" alt="Game"></a>
<a href="something.com"><img src="blah.jpg" alt=""></a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end