$re = '/([a-z-]*[a-z_]+)([_A-Z0-9\.-]+)+(-[a-z_]+)?\.(jar|zip)/m';
$str = 'cdrf_irs-4.5.0-DEV_CDRF-4.5_RC3-SNAPSHOT-schema.zip';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);