// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)([A-Z0-9]+[A-Z0-9]+)|\[.*?\]|\".*?\""#).unwrap();
let string = "Apply B23C to 23AB, ACDC1, 17X56QQE and DC45, then press [Remove] to open the screen \"Installation\".";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}