$re = '/(^|\s)((https?:\/\/)?[\w-]+(\.[a-z-]+)+\.?(:\d+)?(\/\S*)?)/im';
$str = 'bit.ly/00a0sa0sasaxsdd
http://bit.ly/00a0sa0sasaxsdd
https://bit.ly/00a0sa0sasaxsdd
http://www.terra.es/asasa
https://www.terra.es/asasa
https://www.terra.es.com/asasas
https://www.terra2.es.com/asasas
3.0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);