$re = '/(?<=\[%).*?(?=%])/m';
$str = 'test [%variable1%] test test [%variable2%]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);