// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([a-z]+\:\/+)([^\/\s]*)([a-z0-9\-@\^=%&;\/~\+]*)[\?]?([^ \#]*)#?([^ \#]*)").unwrap();
let string = "Bob: Hey there, have you checked https://www.facebook.com ?
(ignore) https://github.com/justsml?tab=activity#top (ignore this too)
smb:///winbox/dfs/ - ipp://printer
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}