#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\w(?=\w{4})"
Local $sString = "1234567891234567" & @CRLF & _
"123456789" & @CRLF & _
"1234567" & @CRLF & _
"12345" & @CRLF & _
"Z2348348342"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)