const regex = /\w(?=\w{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w(?=\\w{4})', 'gm')
const str = `1234567891234567
123456789
1234567
12345
Z2348348342`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);