#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:0|(?:\+|00) ?31 ?)(?:(?:[1-9] ?(?:[0-9] ?){8})|(?:6 ?-? ?[1-9] ?(?:[0-9] ?){7})|(?:[1,2,3,4,5,7,8,9]\d ?-? ?[1-9] ?(?:[0-9] ?){6})|(?:[1,2,3,4,5,7,8,9]\d{2} ?-? ?[1-9] ?(?:[0-9] ?){5}))$"
Local $sString = "this is a list of numbers inline 06-12345678 gggf0612345678 06 12345678 0101234567 010-1234567 dfgfdg010 1234567 010 12 34 567 more 010 12 34567 yes 010 1234 567 and more +31612345678 and more and this 0031123456789" & @CRLF & _
"dfgfd and here are some separate lines:" & @CRLF & _
"06-12345678" & @CRLF & _
"0612345678" & @CRLF & _
"0612345678" & @CRLF & _
"0101234567" & @CRLF & _
"010-1234567" & @CRLF & _
"010 1234567" & @CRLF & _
"010 12 34 567" & @CRLF & _
"010 12 34567" & @CRLF & _
"010 1234 567" & @CRLF & _
"+31612345678" & @CRLF & _
"0031123456789" & @CRLF & _
"ghf@fghgfh.coml" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")