#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^([\w\ ]+)(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?/?$"
Local $sString = "hey/dude/yo%20man%2C%20what%27s%20up%3F/"
Local $sSubst = "route.php?1=$1&2=$2&3=$3&4=$4&5=$5&6=$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)