package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([\w\ ]+)(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?/?$`)
var str = `hey/dude/yo%20man%2C%20what%27s%20up%3F/`
var substitution = "route.php?1=$1&2=$2&3=$3&4=$4&5=$5&6=$6"
fmt.Println(re.ReplaceAllString(str, substitution))
}