import Foundation
let pattern = #"^([\w\ ]+)(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?(?:/([\w\ ]+))?/?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"hey/dude/yo%20man%2C%20what%27s%20up%3F/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"route.php?1=$1&2=$2&3=$3&4=$4&5=$5&6=$6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)