package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\w\b \b\w\b`)
var str = []byte(`U S lknsf l kasf
U.S. olasndflkasdas
S F F S F `)
var substitution = []byte("US")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}