$re = '/^\d+$/m';
$str = '456564
4566 456546
4545h54
hhhhh
355634546546';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);