$re = '/R\$\s^\d{1,3}(?:\.\d{3})*,\d{2}/';
$str = 'R$ 110,00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);