import Foundation
let pattern = #"\$[^\(\);]+(?:\(\))?(?:\.[^\(\)]+(?:\(\))?)*?;"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$get.q.htmlentities();
var val = $(this).val();
var val2 = $().val();
var val3 = "$placeholder;";
$get.q.htmlentities().func2();
$get.q.htmlentities().func2().wuuuut();
$get.q.htmlentities().func2(3);
$get.q.htmlentities(3).func2();
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)