$re = '/(?:console\.(?!log))/m';
$str = 'console.log(
console.stack(
consolelog(
console';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);