#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)house\s+(\d+[-\s]?[a-zA-Z]?)\b"
Local $sString = "FLOWERS 527 OFFICE 1217 HOUSE 1" & @CRLF & _
"ONE WAY 614 HOUSE 4-C" & @CRLF & _
"OTHER WAY 371 DEPARTMENT 209 HOUSE 25 C" & @CRLF & _
"SAINT GEORGE 378 DEPARTMENT 808 HOUSE 3 C BLA BLA BLA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")