using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""postcode\""\:\""(?<postcode>[^\""]+)\""";
string input = @"{""line1"":""1 THE STREET"",""line2"":""TOWN"",""line3"":""CITY"",""line4"":null,""postcode"":""AB11AB"",""country"":""GREAT BRITAIN"",""startDate"":944697600000,""type"":""Residential""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}