package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\"postcode\"\:\"(?<postcode>[^\"]+)\"`)
var str = `{"line1":"1 THE STREET","line2":"TOWN","line3":"CITY","line4":null,"postcode":"AB11AB","country":"GREAT BRITAIN","startDate":944697600000,"type":"Residential"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}