import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"postcode\\\"\\:\\\"(?<postcode>[^\\\"]+)\\\"";
final String string = "{\"line1\":\"1 THE STREET\",\"line2\":\"TOWN\",\"line3\":\"CITY\",\"line4\":null,\"postcode\":\"AB11AB\",\"country\":\"GREAT BRITAIN\",\"startDate\":944697600000,\"type\":\"Residential\"}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}