import Foundation
let pattern = #"\"postcode\"\:\"(?<postcode>[^\"]+)\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"{"line1":"1 THE STREET","line2":"TOWN","line3":"CITY","line4":null,"postcode":"AB11AB","country":"GREAT BRITAIN","startDate":944697600000,"type":"Residential"}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)