re = /^.*Woznica wola:.+\.$/m
str = 'Woznica wola: Test.
Woznica wola: Test, kurde.
Woznica wola: Test!
Woznica wola: Test, kurde!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end