# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?!aBc)[aA][bB][cC]"
test_str = ("This should match:\n"
"ABC\n"
"ABc\n"
"AbC\n"
"Abc\n"
"aBC\n"
"abC\n"
"abc\n\n"
"Text with abc in it should also match. Even if it is within a word like in Barabc Obama.\n\n"
"This must not match:\n"
"aBc\n"
"cba\n"
"aaa\n"
"bbb\n"
"ccc\n"
"bac\n"
"ABBA")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.