using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"- - .* ""GET .*\?do\=.*";
string input = @"- - [27/Sep/2013:12:41:21 +0200] ""GET /shop/index.php?do=/blog/add HTTP/1.1"" 301 566 ""http://www.tld.com/shop/"" ""Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1;)""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}