$re = '/^(?P<major>|[0-9]+)\.(?P<minor>[0-9]+)\.(?P<patch>|[0-9]+)-(?:(?P<GA>GA$)|(?P<PRO>PRO$)|(?P<SNAPSHOT>SNAPSHOT$)|(?P<RC>RC$))$/m';
$str = '1.2.6-RC
1.2.4-GA
1.2.6-PRO
1.2.6-SNAPSHOT
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);