$re = '/u\'([^\']*)\'/';
$str = '{
u\'state\': u\'CA\',
u\'page_size\': u\'1000\',
u\'market\': u\'Western\',
u\'requested_at\': u\'2014-10-28T00:00:00+00:00\'
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);