$re = '/(\s+(#[^\n]*\n)?)/m';
$str = 'some text
E-mail Address: user123@gmail.com
Billing Address:
Harry Smith
3423 My Lane
SOME CITY, CA 94105
United States
I want to match';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);