using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^0-9\n]+)[0-9]?.*";
string input = @"abc123
#$%@#<>@<123
abc
abc @#@#@-122
a123b456";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}