#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "return.*(\s+)?$"
Local $sString = "local function test()" & @CRLF & _
" print("Hello!")" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"return thing"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")