using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([а-яА-я]+\s[а-яА-я]+\s[а-яА-я]+)|([\w]+\s[\w]+\s[\w]+)|([\w]+\s[\w]+)";
string substitution = @"";
string input = @"Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/
IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~`:""{};'[]|\<>?,./
IVANOV Ivan !@#$$^&*(_+1234567890-=~`:""{};'[]|\<>?,./";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}