import Foundation
let pattern = #"([а-яА-я]+\s[а-яА-я]+\s[а-яА-я]+)|([\w]+\s[\w]+\s[\w]+)|([\w]+\s[\w]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/
IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~`:"{};'[]|\<>?,./
IVANOV Ivan !@#$$^&*(_+1234567890-=~`:"{};'[]|\<>?,./
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)