package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[^"]*"(*SKIP)(*F)|\s+`)
var str = ` abc def " gh i " jkl " m n o p " qrst "abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}