$re = '/COM\s([REV|LIB])/m';
$str = 'COM REV
COM EV
COM V
COM |
COM L
COM I
COM B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);